20008 | Order not found using ID

WPPizza – A Restaurant Plugin for WordPress Support General Support 20008 | Order not found using ID

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #46653
    deinegrafiker
    Participant

    Hi there,
    i cant place an order atm.
    Everytime i try to, i get this error as mentioned at topic title.

    WP-DEBUG Log:

    
    [23-Feb-2020 23:08:59 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    [23-Feb-2020 23:08:59 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    [23-Feb-2020 23:09:04 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    [23-Feb-2020 23:09:04 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    [23-Feb-2020 23:09:05 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    [23-Feb-2020 23:09:05 UTC] PHP Notice:  Undefined index: hash in some-folder-stuff/wp-content/plugins/wppizza/classes/class.wppizza.db.php on line 757
    
    

    Any chance someone could help me with that? I never changed a line of wppizza plugin nor any extension.

    Greetings,
    Jens

    #46655
    Olly
    Admin & Mod

    without at least a url/link , I cannot really do/say much….

    #46656
    deinegrafiker
    Participant
    This reply has been marked as private.
    #46661
    Olly
    Admin & Mod

    do you have “wppizza -> settings -> use SMTP -> SMTP Debug” enabled ?

    #46662
    deinegrafiker
    Participant

    At this moment yes, it’s activated. Don’t tell me that’s causing the problem :-/

    #46664
    Olly
    Admin & Mod

    >Don’t tell me that’s causing the problem

    errr, yes.
    as it says:
    “This must be OFF on production servers. Development/Testing only. (Will output full smtp connection log in your browsers console”)

    (admittedly, maybe that could be clarified somewhat, but if you have this on, orders will not work and it will only outputs smtp debug stuff for ….. debugging smtp issues)

    #46665
    Olly
    Admin & Mod

    that said, turning this off might *not* solve the underlying issue , but if it’s on it wont reveal the underlying issue
    (if any)
    (hope that makes sense)

    in short: if you turn it off and still have problems, let me know and we’ll investigate to get to the root cause of it …..

    #46666
    deinegrafiker
    Participant

    Alright, thank you so far.
    I turned it off but now the error get displayed on the website after i placed the order.

    ERROR: 20008

    Order not found using ID

    #46667
    Olly
    Admin & Mod

    ok , let me have a rummage around for a bit .
    i’ll get back to you when i know more (might not be until tomorrow though…)

    #46668
    Olly
    Admin & Mod

    quick question (if you know):
    did you have the same issue with 3.10.9 or only since 3.10.10 of the wppizza plugin ?
    (if not applicable, let me know please. there’s something that had to change in 3.10.10 but *perhaps* with undesired effects though)

    #46669
    hansenL
    Participant

    I have the exact same issue with my site 🙁

    #46674
    Olly
    Admin & Mod

    can you please update to 3.10.11 (which is in effect 3.10.9 again) and tell me if this solves the issues ?
    i seem to have broken something in 3.10.10 when trying to make things better, so 3.10.11 is – in effect – 3.10.9 again until i find out what may be the issue

    #46675
    deinegrafiker
    Participant

    Hey Olly,
    thank you for that update – it’s working now.

    I also noticed that all my “add ingredients”-settings are back and working again, which wasnt the case at 3.10.10

    Thank you alot 🙂

    #46680
    Olly
    Admin & Mod

    > it’s working now.
    glad to hear it

    what exactly was not working with the add ingredients though as i am not quite sure how the broken 3.10.10 could have affected it ?
    (so i can make sure this doesnt happen in the next update)

    #46682
    deinegrafiker
    Participant

    the option ” allow customers to add additional ingredients to this item ?: ” inside the product-page was unchecked in every product as far as i can tell

    #46683
    Olly
    Admin & Mod

    Hmm, i’ll see if i can reproduce this somehow, but I cannot see how the the changes that were made in 3.10.10 – even the bug introduced there – could have affected this at all to be honest

Viewing 16 posts - 1 through 16 (of 16 total)
  • The topic ‘20008 | Order not found using ID’ is closed to new replies.