Anyone else got cloud print problems?

WPPizza – A Restaurant Plugin for WordPress Support General Support Anyone else got cloud print problems?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #37448
    Kim Koldtoft

      I have google cloud print set up for printing orders and normally it works fine.

      But today, a few hours ago, it just stopped working out of the blue.

      • The printer is unchanged (same IP settings etc.)
      • It still works fine when printing from windows / chrome
      • Nothing was changed when it stopped working
      • I tried disabling and enabling the plugin. No change
      • I trued updating the Token. No change

      Here is a screenshot of my settings.

      I am using the default HTML template, slightly modified. If I preview and print it from chrome, it works fine. It’s like the print job is not being sent from Wp-pizza cloud print.

      Admin & Mod

        have you checked the wppizza/logs directory for any error logs in there (or indeed your debug.log provided you enabled debug)

        Admin & Mod

          PS: with all this GDPR going on , you might have to re-request/re-setup authorization for cloudprint as per directions (though it still works here as it always did)

          Kim Koldtoft

            In google cloud print, the printer registers fine as “online” and as shown in this screenshot, I can print from it, when using chrome/windows.

            From google cloud print watch

            And as shown here, the printer registers as online

            printer is online in google.

            Kim Koldtoft

              Thank you for the quick reply Olly.

              Yes, GDPR did cross my mind, which is why i thought to ask here, as it might be happening to someone / everyone else, but apparently not.

              I updated the client secret as well and re-saved the credentials in but still nothing.

              I can’t check the logs right now, as I have recently moved the server, and my developer is offline right now. Is there any way to check the logs from WordPress?

              Kim Koldtoft

                I found the problem and managed to fix it. It was a read/write file permission issue. I think maybe the developer changed some of the file permissions, and that is what made it stop working.

                I managed to get access to the log files, but there was nothing there. (maybe also a write permission issue)

                I checked the following..

                This has an empty index.html and a readme.txt file that says ===== TO DO ======

                This just has an empty index.html file

                Has a debug.log file, but it only has a few lines that are dated to 2017 so I think unrelated to this problem.

                However, I checked the error log for Apache2 and found what looked like a “read / write” permission issue.

                So I have updated the file permissions and that fixed it.

                Now I am just afraid that my site is not secure…

              Viewing 6 posts - 1 through 6 (of 6 total)
              • The topic ‘Anyone else got cloud print problems?’ is closed to new replies.