Order Repurchase not working correctly

WPPizza – A Restaurant Plugin for WordPress Support General Support Order Repurchase not working correctly

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #57900
    johanfmp
    Participant

    Olly,

    We use the option for order repurchasing since we started to use wp-pizza without any problem. Today we noticed (and we are able to replicate) that it is possible to order items that are no longer published (they have been moved tot the recycle bin) when adding them to the shopping cart from the oderhistory page. Is it possible to adjust wp-pizza in some way that it is only possible to re-order items from the order history page that are marked as published?

    We have some items that are not available for some time due to various reasons. We don’t want to delete them because in the future we will put them back available. So in the admin panel we moved them to the recycle bin within the wp-pizza items. On the site when you do a search for them, they can’t be found (and not ordered). But when a user has odered them before he can reorder them from within the order history page without any problem. This order then passes without any problems.

    I don’t know if it’s a lot of work to only show the “+” on the orderhistory page when the item has status published and otherwise leave this blanc.

    Kind regards,

    Johan

    #58003
    Olly
    Admin & Mod

    Hi

    First of all, sorry for the late reply. For some reasons I did not get any notifications in the last few days that there were any new topics posted on here.

    Regarding your post: Thanks for the detailed report. I’ll try to replicate this here and update the plugin with a fix if indeed this is an oversight – as it may well be – on my part and not some 3rd party plugin or filter that is changing post statusses or some such thing

    might take a couple of days or so though

    #58011
    Olly
    Admin & Mod

    Sorry, but I cannot replicate this here.

    In fact the bit that deals with the display of the [+] button etc for repurchasing things specifically checks that the post_status is indeed “publish” and nothing else.

    Have you tried de-activating all other plugins and used a default (20something) theme ?

    Or perhaps I’m looking in the wrong place. Can you post a screenshot somewhere of the page where you are seeing this , just so I know we are talking about the same thing

    #58013
    johanfmp
    Participant
    This reply has been marked as private.
    #58045
    johanfmp
    Participant

    The first tests with the new updated version 3.13.9 are ok now, the problem seems solved. Will keep you informed if I notice something not working correctly in certain cases. You delivered once again very good work!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.