Problems with selecting date after 28 febr.

WPPizza – A Restaurant Plugin for WordPress Support Add-Ons Extensions Preorder Support Problems with selecting date after 28 febr.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #66359
    johanfmp
    Participant

      Olly,

      We are having a big problem with the preorder plugin. It’s not possible to place an order after 28 februari. Could this problem be caused because february has 29 days this year? We work with whole days when ordering and users can order up to 28 days in advance. Even if we set the preoder limit to 7 it’s not possible to place an order.
      The site gives the message to make a selection from the available dates. The dates a visible (highlighted).

      The site is: https://dewiezebakker.be

      #66363
      Olly
      Admin & Mod

        without seeing your settings in the preorder plugin , I cannot really comment other than to say , have you enabled debug and checked your debug log to see if there’s any hint there ?
        https://docs.wp-pizza.com/troubleshooting/

        #66364
        johanfmp
        Participant

          Olly,

          I send screenshots of the settings and the debug.log to your mail.
          Nothing had been changed on the site regarding wp-pizza or other plugins.

          We can select 28febr as a delivery/pickup date but no date after that.

          #66368
          Olly
          Admin & Mod

            works all fine here with your settings.
            your debug however is complaining about session start – for this see here: https://docs.wp-pizza.com/troubleshooting/?section=headers-already-sent
            secondly: have you tried enabling the caching bypass option (in the preorder plugin settings ?)
            i.e enable
            Caching: Turn this off if you experience problems with date/times not being set correctly

            #66369
            johanfmp
            Participant

              I will give that a try. Strange thing is that nothing has been changed and 28 feb can be selected but not 1 mar or further in the future.

              #66370
              johanfmp
              Participant

                Enabling or disabling caching bypass doesn’t solve anything. Problem stays the same: we can select 28feb and all works fine. If we try to select any other date it doesn’t work.

                #66371
                johanfmp
                Participant
                  This reply has been marked as private.
                  #66372
                  Olly
                  Admin & Mod

                    your debug is still saying
                    …session_start(): Session cannot be started after headers have already been sent….

                    #66373
                    Olly
                    Admin & Mod
                      This reply has been marked as private.
                      #66374
                      johanfmp
                      Participant

                        I’m going crazy… if I select the next available date which is 28/02 it works, I select 01/03/ it doesn’t, I select 28/02 again and it works… All in the same screen without changing anything…
                        Nothing changes apart from picking another date…

                        #66375
                        johanfmp
                        Participant
                          This reply has been marked as private.
                          #66376
                          johanfmp
                          Participant

                            Olly, it seems that the preoder (picker) has a problem with the dutch language when it’s a leap year. When I set the language for the site to English US it works. When I revert it back to Dutch (Nederlands) it doesn’t work as it should. No date after 28/02 can be selected.

                            #66377
                            Olly
                            Admin & Mod
                              This reply has been marked as private.
                              #66378
                              Olly
                              Admin & Mod

                                >Olly, it seems that the preoder (picker) has a problem with the dutch language
                                interesting and quite possible (may be dependent on date format settings)
                                i’ll play around with it here to see what is going on (I guess you have your – at least temporary – workaround )

                                #66379
                                johanfmp
                                Participant

                                  I hope you can sort it out, it’s a language problem in dutch with the leap year.

                                  FYI Changing to another city or UTC+1 in the time zone results in the same error when the language is set to dutch.
                                  The only problem is that when the language is set to English all dates are shown in English on the site and the customer doesn’t want this.

                                  #66380
                                  johanfmp
                                  Participant

                                    Olly,
                                    I found how to make it work in with the site language set to Dutch:
                                    – In the wordpress settings The date is set to j F Y (26 Februari 2024)
                                    – In the preorder plugin the date format was original set to 26 Feb 2024. Here it works only when site language is set to English
                                    – In the preorder plugin the date format was changed to 26 February 2024 and now it works in both languages English and Dutch

                                    #66382
                                    Olly
                                    Admin & Mod

                                      ok. noted (thanks for jumping through the hoops to narrow things down and providing a workaround fix though)
                                      Still a bit strange to be honest, so I’ll dig around a bit to find out what’s going on (and of course fix it if it’s doable)

                                      #66386
                                      Olly
                                      Admin & Mod

                                        as a summary here (in case someone experiences the same or similar issue and comes across this thread)

                                        – simply changing the date format in the preorder plugin (ignore WP settings etc) fixes things it appears

                                        As mentioned above, I’ll see if this is fixable.
                                        This may actually involve removing the “26 Feb 2024” format option altogether ….yet to be determined …
                                        In any event, it will be addressed in the next update of the plugin one way or another


                                        @johanfmp

                                        Again , thanks for doing the donkey work here to narrow this down , much appreciated and very helpful

                                        #66389
                                        Olly
                                        Admin & Mod

                                          for completeness sake: as it stands, this problem will also occur if setting the date format to “Feb 26 2024” (i.e any 3 letter month format), always depending on overall language set

                                        Viewing 19 posts - 1 through 19 (of 19 total)
                                        • You must be logged in to reply to this topic.