Redirect after payment

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #11540
    barricudasdenver
    Participant

    Hello Olly… hoping you can assist.

    Our customers are placing orders and not clicking the link to return to our site. So they are paying and getting charged but we are not getting the order. I changed the Return to site link to say “YOU MUST CLICK HERE TO COMPLETE YOUR ORDER.” but that is still not helping. In looking at options to fix this I ran across Relay Response on Authorize.net and was wondering if the payment gateway was compatible with this option and if it would keep customers from having to click to return to our site.

    Thanks is advance… Mitch

    #11543
    Olly
    Admin & Mod

    did you read the setup instructions here:
    https://www.wp-pizza.com/downloads/wppizza-authorizenet-gateway/
    ?
    especially the “silent post url” ?

    no one should have to click on anything as the execution happens in the background…

    #11680
    barricudasdenver
    Participant
    This reply has been marked as private.
    #11681
    Olly
    Admin & Mod

    can you send me the output of your system info in
    wppizza->tools : system info please to dev[at]wp-pizza.com and perhaps the output when clicking “show php configuration” (alternatively give me access to the wp backend, but that’s up to you)

    also , how does the php_mail.log end up in your ipn directory of the plugin ?

    furthermore, the permissions should not (have to ) be changed on the ipn.php file – you can if you really want to, but i would not recommend it
    it’s the logs directory that has to be writable to by the plugin (which it would normally be automatically)

    #11682
    Olly
    Admin & Mod

    funny thing is, it shouldnt really work if the silent post url does not send anything as just returning to the site when clicking on that link should not do much..i’ll double check though

    #11683
    barricudasdenver
    Participant
    This reply has been marked as private.
    #11685
    Olly
    Admin & Mod

    now we fixed it (and for the benefit of anyone else reading this)
    setting the permissions to anything higher than 755 stops the ipn.php (silent post url) from working on some servers (which is fair enough)

    so, make sure your silent post url when accessed from your browser is nothing other but a blank page

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Redirect after payment’ is closed to new replies.