Error: WP Error: cURL error 35

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #27545
    dide
    Participant

    Hello!

    Sorry for my bad english.

    After installing the plugin Google Cloud Print i get this error on the Licence Page:

    Error: WP Error: cURL error 35: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

    Thanks for your help!

    Dominic

    #27553
    Olly
    Admin & Mod

    to start off with whats your
    OS and OS version
    libcurl version
    php version
    openssl version

    did you also/already speak to your host about this ? this is a server/setup issue

    #27554
    dide
    Participant

    Thanks for your help! I did not find any information about libcurl.
    I am my own hoster, its a root server.

    System Windows NT H2677284 6.3 build 9200 (Windows Server 2012 R2 Standard Edition) i586

    PHP 5.4.45

    curl
    cURL support enabled
    cURL Information 7.42.1
    Age 3
    Features
    AsynchDNS Yes
    Debug No
    GSS-Negotiate No
    IDN No
    IPv6 Yes
    Largefile Yes
    NTLM Yes
    SPNEGO Yes
    SSL Yes
    SSPI Yes
    krb4 No
    libz Yes
    CharConv No
    Protocols dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
    Host i386-pc-win32
    SSL Version OpenSSL/0.9.8zf
    ZLib Version 1.2.7
    libSSH Version libssh2/1.5.0

    SSL Version OpenSSL/0.9.8zf

    #27555
    Olly
    Admin & Mod

    hmm, i know nothing about win servers really.
    however – though that’s just a wild stab in the dark – you could try the following
    (make a backup of the file you are editing – if it falls over revert to that backup)

    in the plugin you find the following file

    /inc/HttpRequest.Class.php

    on approx line 49 you will find
    curl_setopt( $this->ch, CURLOPT_HTTPAUTH,CURLAUTH_ANY);
    right AFTER that ADD
    curl_setopt($this->ch, CURLOPT_CAINFO, ''.ABSPATH . WPINC . '/certificates/ca-bundle.crt');

    and save. let me know if that fixes it (or any other/different errors you might get)

    #27572
    dide
    Participant

    Thanks, but nothing changed. It’s the same problem.

    After check the “Activate Licence” an Save comes the problem red marked:

    Activate License License Status unknown
    Error: WP Error: cURL error 35: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

    #27573
    Olly
    Admin & Mod

    try this line instead
    curl_setopt($this->ch, CURLOPT_SSLVERSION, 6);
    TLS lower than 1.2 is disabled on wp-pizza.com (for good reason)

    forget that. this would affect the cloudprint itself, not the license screen. that’s something completely different. I misunderstood.

    I’ll have to dig around a bit

    which version of wppizza and cloudrpint plugin are you using ?

    #27574
    dide
    Participant

    Ok. Don’t worry, its because of me, I dont tell you clearly the problem.

    It’s only the licence Screen. I use both of the newest versions.

    Cloudprint 4.0.1
    WPPizza 3.0.beta.170427.1

    I don’t know in this moment, if it’s only a Cloudprint Licence problem, or general licence problem with all Add Ons – Give me a little bit. I will check it and answer soon.

    Thanks
    Dominic

    #27575
    Olly
    Admin & Mod

    PS from what i can see your open ssl version is 2 years old
    i would suggest you update this . (this *might* be the issue )

    also what does it say about “Remote post” here
    your.domain.com/wp-admin/edit.php?post_type=wppizza&page=wppizza-tools&tab=sysinfo
    ?

    #27577
    Olly
    Admin & Mod

    PS: version 3 beta has been updated (although that has nothing to do with your issue, just mentioning it )
    see blog.wp-pizza.com

    #27579
    dide
    Participant

    Thanks a lot. I logged in to Plesk and changed the Version of PHP from 5 to 7.0.18, so OpenSSL runs in newest version, too.

    My problem is solved! THANKS A LOT!!! 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Error: WP Error: cURL error 35’ is closed to new replies.