Issues with payment stripe ideal

WPPizza – A Restaurant Plugin for WordPress Support Add-Ons Gateways Stripe Issues with payment stripe ideal

Viewing 13 posts - 21 through 33 (of 33 total)
  • Author
    Posts
  • #49136
    Olly
    Admin & Mod

    please also enable debug on your site like so
    https://docs.wp-pizza.com/troubleshooting/

    #49138
    cliff Smit
    Participant
    This reply has been marked as private.
    #49140
    Olly
    Admin & Mod

    >this data is the latest received at events
    yeah that’s the problem, there’s the one missing that says “xyz was charged”
    ok, let’s try something else first of all with my api keys
    (in the next private post – give me a second, i need to set something up )
    in the meantime – if you have not done so already – please enable debug as mentioned above
    https://docs.wp-pizza.com/troubleshooting/

    #49141
    Olly
    Admin & Mod
    This reply has been marked as private.
    #49142
    cliff Smit
    Participant

    i tink i have the debug on i set the setting on true

    #49143
    cliff Smit
    Participant
    This reply has been marked as private.
    #49144
    cliff Smit
    Participant
    This reply has been marked as private.
    #49145
    Olly
    Admin & Mod

    hang on a minute
    your webhook details set up in your stripe account have not been set up to send to any event
    click on update and select/click “receive all events” and save

    (looks like i’ll have to update the docs to make that explicit)

    #49146
    Olly
    Admin & Mod

    not withstanding that the first problem is that your webhook is not set up to send to any events,
    now you have made an order with my testkeys, your server is responding with this

    
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>503 Service Unavailable</title>
    </head><body>
    <h1>Service Unavailable</h1>
    <p>The server is temporarily unable to service your
    request due to maintenance downtime or capacity
    problems. Please try again later.</p>
    </body></html>

    so something’s wrong at your server end (might only be temporary though, so perhaps you want to try one more order here)

    #49147
    cliff Smit
    Participant

    okay i have all events and save i will try again after that

    #49152
    Olly
    Admin & Mod

    ok, use own test keys again though (otherwise it wont make any difference what you set in your webhook as you’d be still using mine – in fact I have now disabled this again in *my* stripe account as we pretty much know what the issue is here now)

    #49153
    cliff Smit
    Participant

    okay I have reset my test keys do I have to contact my server if this problem persists or can I change something myself?

    #49154
    Olly
    Admin & Mod

    if your server responds with a 503 only your host/server admin will know why
    (unless you are a server admin and know how to find, read and interpret logfiles)

    i’d suggest you try an order first and see what happens (and let the “processing order” page reload a few times -like for a minute or so – , just in case there’s a very slow response)

Viewing 13 posts - 21 through 33 (of 33 total)
  • You must be logged in to reply to this topic.